六角形状面に四角形メッシュを左右対称に作成する方法

カテゴリー 作成日/修正日 2015/9/14 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Mesh→Surface→Create GUI NO TUI surface <#> scheme stransition キーワード 対称,メッシュ,六角形 Key Word STransition,Symmetry,Hexagon 六角形状面に四角形メッシュを左右対称に作成する方法について(Scheme Stransition)...

Curveの近傍をサイズを指定してメッシュを細分化する方法

カテゴリー作成日/修正日2016/7/232016/7/23対応Trelisバージョン15.0.0 → 16.0.3カテゴリーMesh→ Vertex→ ModifyGUIMesh → Surface → Refine →General RefinementTUIrefine curve <id>s size <#>bias 1 depth 1キーワードメッシュ,細分化,カーブ,サイズKey...

特定のGroup内のEntityを表示する方法

カテゴリー 作成日/修正日 2017/3/24 2017/3/24 対応Trelisバージョン 16.2.2 → 16.3.0 カテゴリー Draw→Group→ Entity GUI Draw→Group→ Entity TUI draw ENTITY in volume in group <$$$> キーワード グループ,エンティティー,表示 Key Word Draw,Entity,Group 特定のGroup内のEntityを表示する方法(Draw_Entity_in_Group)...

座標軸に平行な円筒曲面で立体形状を分割する方法

カテゴリー 作成日/修正日 2015/10/9 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4 カテゴリー Geometry→Volume→Modify GUI Geometry→Volume→Webcutting→Cylinder TUI webcut body <id> with cylinder radius <#> axis y center <#> <#> <#> キーワード 立体,分割,曲面,曲面,円筒...

二面間の角度を測量する方法

カテゴリー 作成日/修正日 2017/3/22 2017/3/22 対応Trelisバージョン 16.2.2 → 16.3.0 カテゴリー Measure→Surface→ Angle GUI Measure→Surface→ Angle TUI measure angle direction surface <id> with direction surface <id> キーワード 面,方向,角度 Key Word Surface,Direction,Angle...

Trelis起動時にコマンドを自動実行する方法

カテゴリー作成日/修正日2016/2/22016/2/2対応Trelisバージョン15.0.1 → 15.2.0カテゴリーOperation→ Auto→ CommandGUINOTUINOキーワード起動,コマンド,自動,実行Key WordCommand,Auto,PlayTrelis起動時にコマンドを自動実行する方法について(Auto-Run-Command)Trelisで起動時にDefaultで設定されているOption...

面を指定ベクトルの方向に押し出してVolumeを作成する方法

カテゴリー 作成日/修正日 2016/12/3 2016/12/3 対応Trelisバージョン 15.0.0 → 16.0.3 カテゴリー Geometry→ Volume → Create GUI Geometry→ Volume → Create →Sweep TUI sweep surface <id>s sweep vector <# # #> distance <#> キーワード 面,押し出し,方向ベクトル Key Word...

Volumeの体積を計算する方法

カテゴリー 作成日/修正日 2015/8/21 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4 カテゴリー Calculate→Volume→Volume GUI Properties Page→Geometry→Volume→Calc TUI list volume <id> geometry キーワード 計算,体積 Key Word Calculate, Volume Volumeの体積の計算方法について(Calculate-Volume)...

Trelisのコマンドパネルのボタン構成と主な機能

カテゴリー 作成日/修正日 2015/10/20 2015/11/3 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Operation→Basic→GUI→Command Panel GUI Command Panel TUI NO キーワード コマンドパネル,構成,機能 Key Word Command,Panel,Distribution,Function Trelisのコマンドパネルのボタン構成と主な機能について(Command-Panel)...

Trelisの形状についての構成要素Entityの概念

カテゴリー 作成日/修正日 2015/10/21 2015/11/3 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Geometry→Identity→Entity GUI Power Tool→Geometry Tree TUI NO キーワード 形状,構成要素 Key Word Geometry,Entity Trelisの形状についての構成要素Entityの概念について(Geometry-Entity)...

最新のドキュメント

Hexa Meshで歪み角度の悪い要素を自動修正する方法

カテゴリー作成日/修正日2016/6/52016/6/5対応Trelisバージョン16.0.0 → 16.0.2カテゴリーGeometry→ Surface → CreateGUIMesh→Volume→Clean up hex elementTUIcleanup volume <id>sキーワード歪み角度,自動修正Key WordMesh,Skew,Clean upHexa Meshで歪み角度の悪い要素を自動修正する方法(Mesh-Clean-up-Hexa)Trelisでバージョン16以降からHexa...

機能別チュートリアル一覧

絵を描くには、たった5つの操作を理解するだけでOKです。基本的には、作成だけでできますが、便利な機能として、ブーリアン、移動、削除、さらに修正が利用できます。


Create (作成)は、形状を新たに作成したり、既存の形状から作成したりする機能です。


 

Modify (編集・修正・修復)は、既存の形状を編集や微修正を行ったり、壊れた形状を修復する機能です。修復は、特に他のCADから形状を読み込んだ場合に形状が壊れているときに利用します。修復機能で形状が修復できない場合は、元のCADから互換性の良い型式で出力したり、場合によっては、元のCADで修正を行う必要があります。


 

Boolean (ブーリアン)は、形状を足し算したり、引き算すしたり、掛け算(共通部分)を行う機能です。一般的に、和、差、積と言われます。この他、Cubitには、ブーリアン系のコマンドとして、Imprint/MergeやWebcutが利用できます。Imprintは、交線を求める機能、Mergeは、同じ形の形状が同じ場所にあった場合に連結する機能です。Webcutはサーフェースやボリューム、ボディなどで既存の形状を分割する機能です


 

Translate (座標変換)は、形状を移動、回転、反転、スケーリングする機能です。


 

Delete (削除)は、形状を削除する機能です。Cubitでは、下位のジオメトリを残して削除することが可能です。


 

Webcut (形状分割)は、形状を分割する機能です。ヘキサメッシュ作成に先立ち、Webcut機能で、ヘキサメッシュ可能な形状に分割していきます。ヘキサメッシュ作成に必要な作業は、この分割作業に尽きます。ヘキサメッシュを作成するために行うべき作業は、ManyToManyタイプの形状をManyToOneまたは、OneToOneに分割するだけです。Cubitでは、この作業のために便利なWebcutツールを提供しております。


 

Virtual Geometry (バーチャルジオメトリ)は、CADのSolidモデリング機能(Real Geometry)では、対応できない、面の合成や面の分割をする機能です。一般的にCADでは、連続性のある面しか合成できません。また、CADは、メッシュを作成することを意識して開発しておらず、実際の物体の表面を表現するために、複数の数学的に定義可能な連続な面に分けて物体の表面を表現します。このように複数に分けて定義されたサーフェースに対して、ユーザーが希望するメッシュを作成することができない場合があります。CubitのVirtual Geometry機能を利用すると、CAD機能で合成できない数学的に連続性のない面を仮想的に合成することができます。