指定したVolume内のElementのID番号を変更する方法

カテゴリー 作成日/修正日 2017/3/19 2017/3/19 対応Trelisバージョン 15.0.0 → 16.3.0 カテゴリー Mesh→Element→ Modify GUI Mesh→Volume→ Renumber TUI renumber face all in volume <id> start_id 1 uniqueids キーワード ボリューム,要素,番号,変更 Key Word Mesh,Volume,Element ID,Renumber...

Curve上に分割数と始点と拡大率を指定してNodeを作成する方法

カテゴリー 作成日/修正日 2015/9/15 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Mesh→Curve→Create GUI Mesh→Curves→Attribute→bias→Intervals & bias TUI curve <id> interval <#>, curve <id> scheme bias factor <#>  start vertex...

座標値を指定してVertexを作成する方法

カテゴリー 作成日/修正日 2015/9/10 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Geometry→Vertex→Create GUI Geometry→Vertices→Coordinate TUI create vertex <#> <#> <#> キーワード 座標値、節点 Key Word Vertex、Coordinate...

立体の角部を丸面で面取りする方法

カテゴリー 作成日/修正日 2015/8/24 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4 カテゴリー Geometry→Curve→Modify GUI Geometry → Curves→ Modify Curves→Tweak→Fillet Radius TUI tweak curve <id> fillet radius <#> <#> キーワード 面取り,丸面,エッジ Key Word...

Meshが作成されていないVolumeのみをMapで作成する方法

カテゴリー 作成日/修正日 2016/11/127 2016/11/27 対応Trelisバージョン 15.0.0 → 16.0.3 カテゴリー Mesh→ Volume→ Create GUI NO TUI with not is_meshed キーワード メッシュ,未作成,指定 Key Word Meshed,Create,Hex Meshが作成されていないVolumeのみをMapでMesh作成する方法(Mesh_not_is_Meshed) TrelisでMesh未作成のVolumeに対してMap...

複数のBlockを一つにまとめる方法

カテゴリー 作成日/修正日 2015/11/13 2015/11/13 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Group→Block→Combine GUI NO TUI block <id> volume all in block <id>s キーワード 境界,ブロック,まとめ Key Word Group,Block,Combine 複数のBlockを一つにまとめる方法について(Block-Combine)...

2点のNodeをマージして一致させる方法

カテゴリー 作成日/修正日 2015/11/5 2015/11/5 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Mesh → Node → Modify GUI Mesh →Node → Merge Node TUI merge node <id> <id> キーワード ノード,マージ,一致,消去 Key Word Node,Merge,Delete 2点のNodeをマージして一致させる方法について(Merge-Node)...

Paveで内部が周辺と異なるメッシュサイズで作成する方法

カテゴリー 作成日/修正日 2016/6/23 2016/6/23 対応Trelisバージョン 15.0.0 → 16.0.2 カテゴリー Mesh→ Surface→ Create GUI Mesh→ Surface→ Interval and Size → Sizing Function TUI surface <id> sizing function constant キーワード メッシュ,ペーブ,サイズ,内外 Key Word Mesh,pave,Sizing,Function,Constant...

円弧から中心点を作成する方法

カテゴリー 作成日/修正日 2015/8/21 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4 カテゴリー Geometry → vertex→ Create GUI Geometry → vertex→ Create→Arc Center TUI create vertex center curve <id> キーワード 円,円弧,中心,中心点 Key Word Curves, Circle ,Arc,Center...

Trelis起動時にコマンドを自動実行する方法

カテゴリー作成日/修正日2016/2/22016/2/2対応Trelisバージョン15.0.1 → 15.2.0カテゴリーOperation→ Auto→ CommandGUINOTUINOキーワード起動,コマンド,自動,実行Key WordCommand,Auto,PlayTrelis起動時にコマンドを自動実行する方法について(Auto-Run-Command)Trelisで起動時にDefaultで設定されているOption...

最新のドキュメント

EdgeについてのFeature-Angleを確認する方法

カテゴリー 作成日/修正日 2017/3/17 2017/3/17 対応Trelisバージョン 15.0.0 → 16.3.1 カテゴリー Mesh→Check→topology GUI Mesh→Surface→ Quality→ Model Edge Check TUI topology check model edge surface all angle <#> draw brief result group キーワード エッジ,角度,法泉,表示 Key Word Mesh,Edge,Check,Angle...

指定したNodeのID番号を変更する方法

カテゴリー 作成日/修正日 2017/3/17 2017/3/17 対応Trelisバージョン 15.0.0 → 16.0.3 カテゴリー Mesh→Node→ Modify GUI Mesh→Nodes→ Renumber TUI renumber node <#> start_id <#> uniqueids キーワード ノード,接点,番号,変更 Key Word Mesh,Node ID,Renumber 指定したNodeのID番号を変更する方法(Mesh_Renumber_Node_ID)...

六面体メッシュの歪み度を確認する方法

カテゴリー 作成日/修正日 2017/2/2 2017/2/2 対応Trelisバージョン 15.0.0 → 16.0.3 カテゴリー Mesh→Volume→ Mesh Quality GUI Mesh→Volume→ Mesh Quality → Quality Metric TUI quality volume <id> equiangle skew global draw mesh キーワード メッシュ,品質,歪み度 Key Word Mesh,Quality,Equiangle, ,Skew...

円の内部に境界層メッシュを作成する方法

カテゴリー 作成日/修正日 2016/12/4 2016/12/4 対応Trelisバージョン 15.0.0 → 16.0.3 カテゴリー Mesh→ Boundary Layer → Create GUI Mesh→ Boundary Layer → Create TUI boundary_layer 1 uniform height <#> growth <#> layers <#> キーワード 境界層,円,カーブ Key Word Boundary Layer,Circle,Curve...

機能別チュートリアル一覧

絵を描くには、たった5つの操作を理解するだけでOKです。基本的には、作成だけでできますが、便利な機能として、ブーリアン、移動、削除、さらに修正が利用できます。


Create (作成)は、形状を新たに作成したり、既存の形状から作成したりする機能です。


 

Modify (編集・修正・修復)は、既存の形状を編集や微修正を行ったり、壊れた形状を修復する機能です。修復は、特に他のCADから形状を読み込んだ場合に形状が壊れているときに利用します。修復機能で形状が修復できない場合は、元のCADから互換性の良い型式で出力したり、場合によっては、元のCADで修正を行う必要があります。


 

Boolean (ブーリアン)は、形状を足し算したり、引き算すしたり、掛け算(共通部分)を行う機能です。一般的に、和、差、積と言われます。この他、Cubitには、ブーリアン系のコマンドとして、Imprint/MergeやWebcutが利用できます。Imprintは、交線を求める機能、Mergeは、同じ形の形状が同じ場所にあった場合に連結する機能です。Webcutはサーフェースやボリューム、ボディなどで既存の形状を分割する機能です


 

Translate (座標変換)は、形状を移動、回転、反転、スケーリングする機能です。


 

Delete (削除)は、形状を削除する機能です。Cubitでは、下位のジオメトリを残して削除することが可能です。


 

Webcut (形状分割)は、形状を分割する機能です。ヘキサメッシュ作成に先立ち、Webcut機能で、ヘキサメッシュ可能な形状に分割していきます。ヘキサメッシュ作成に必要な作業は、この分割作業に尽きます。ヘキサメッシュを作成するために行うべき作業は、ManyToManyタイプの形状をManyToOneまたは、OneToOneに分割するだけです。Cubitでは、この作業のために便利なWebcutツールを提供しております。


 

Virtual Geometry (バーチャルジオメトリ)は、CADのSolidモデリング機能(Real Geometry)では、対応できない、面の合成や面の分割をする機能です。一般的にCADでは、連続性のある面しか合成できません。また、CADは、メッシュを作成することを意識して開発しておらず、実際の物体の表面を表現するために、複数の数学的に定義可能な連続な面に分けて物体の表面を表現します。このように複数に分けて定義されたサーフェースに対して、ユーザーが希望するメッシュを作成することができない場合があります。CubitのVirtual Geometry機能を利用すると、CAD機能で合成できない数学的に連続性のない面を仮想的に合成することができます。