Trelisのコマンドパネルのボタン構成と主な機能

カテゴリー 作成日/修正日 2015/10/20 2015/11/3 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Operation→Basic→GUI→Command Panel GUI Command Panel TUI NO キーワード コマンドパネル,構成,機能 Key Word Command,Panel,Distribution,Function Trelisのコマンドパネルのボタン構成と主な機能について(Command-Panel)...

画面のViewを画像ファイルに出力する方法

カテゴリー作成日/修正日2016/4/52016/4/5対応Trelisバージョン15.0.1 → 16.0.0カテゴリーDisplay → View → HardcopyGUINOTUIhardcopy "File_name" <jpg,png,bmp,tiff,eps>キーワードビュー,ハードコピー,画像,ファイルKey WordView,Hardcopy,Graphic,Window画面のViewを画像ファイルに出力する方法(Display-View-Hardcopy)TrelisでGraphic...

Fluent境界条件でZoneをFluidとSolidに分けて出力する方法

カテゴリー 作成日/修正日 2015/10/27 2015/11/3 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー BC→Block→Media GUI CFD BC →Create Media→CFD Media TUI create media name "Name" solid キーワード 流体,境界,ゾーンタイプ Key Word CFD,Media,Fluid,Solid,Boundary...

Mesh要素から形状を作成する方法

カテゴリー作成日/修正日2016/6/52016/6/5対応Trelisバージョン15.0.1 → 16.0.2カテゴリーGeometry→ Surface → CreateGUIMesh→Volume→Mesh based Geometry →CreateTUIcreate mesh geometry face <id>sキーワードメッシュ要素,面形状Key...

Vertexの近傍を分割回数を指定してメッシュを細分化する方法

カテゴリー作成日/修正日2016/7/232016/7/23対応Trelisバージョン15.0.0 → 16.0.3カテゴリーMesh→ Vertex→ ModifyGUIMesh → Surface → Refine →General RefinementTUIrefine vertex <id>s numsplit <#> bias 1 depth 1キーワードメッシュ,細分化,分割回数Key WordMesh,Refine,Number...

座標軸に回転した平面で立体形状を分割する方法

カテゴリー 作成日/修正日 2015/10/9 2015/11/3 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4 カテゴリー Geometry→Volume→Modify GUI Geometry→Volume→Webcutting→Coordinate Plane TUI webcut body <id. with plane zplane offset <#> rotate <#> about y center <# # #> キーワード...

隣接する六面体Meshの片方だけ細分化する方法

カテゴリー 作成日/修正日 2015/10/4 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4 カテゴリー Mesh→Volume→Refinement→Structure Subdivision GUI NO TUI refine volume <id> using surface <id> キーワード 六面体,隣接、構造メッシュ、細分化 Key Word Mesh ,Refinement,Subdivision、Hexahedral...

ジャーナルファイルの実行を途中で止める方法

カテゴリー 作成日/修正日 2015/9/30 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Journal→Control→Stop GUI NO TUI Stop,Pause キーワード ジャーナル,ファイル,停止 Key Word Journal,stop,Pause ジャーナルファイルの実行を途中で止める方法について(Journal-Control-Stop)...

Entityに固有の名前をつける方法

カテゴリー 作成日/修正日 2015/11/9 2015/11/9 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5,15.1.6 カテゴリー Operation → Entity → Name GUI Power Tool → Geometry tree TUI <$> name "<$>",<$> rename "<$>" キーワード エンティティ,名前,変更 Key Word...

2点のNodeをマージして一致させる方法

カテゴリー 作成日/修正日 2015/11/5 2015/11/5 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Mesh → Node → Modify GUI Mesh →Node → Merge Node TUI merge node <id> <id> キーワード ノード,マージ,一致,消去 Key Word Node,Merge,Delete 2点のNodeをマージして一致させる方法について(Merge-Node)...

最新のドキュメント

座標軸Axisを原点に表示する方法

座標軸Axisを原点に表示する方法

カテゴリー 作成日/修正日 2015/9/8 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Display→Window→Axis GUI Tools→Options→Display→Axis→On TUI graphics axis axis on キーワード 座標軸,原点,表示 Key Word Axis 座標軸Axisを原点に表示する方法について(Display-Axis) TRELIS...

Undoで操作を元に戻す方法

Undoで操作を元に戻す方法

カテゴリー 作成日/修正日 2015/9/8 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Operation→Basic→Undo GUI Tool bars→undo TUI undo キーワード 元に戻す,やり直し Key Word Undo Undoで操作を元に戻す方法について(Undo) TRELIS では形状作成機能については やり直し操作Undoを行うことが出来ます.UndoはTool...

Graphic-Windowの背景色を変更する方法

Graphic-Windowの背景色を変更する方法

カテゴリー 作成日/修正日 2015/9/7 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Display→Window→Color GUI Tools→Options→Display→Background Color TUI color background <bottom_color> <top_color> キーワード 背景色,変更 Key Word Background,Color...

Curveの表示太さを変更する方法

Curveの表示太さを変更する方法

カテゴリー 作成日/修正日 2015/9/7 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Display→Size→Curve GUI Tools→Options→Display→Line Width TUI graphics linewidth <#> キーワード 表示,節点,太さ Key Word Display,Vertex,line,width...

機能別チュートリアル一覧

絵を描くには、たった5つの操作を理解するだけでOKです。基本的には、作成だけでできますが、便利な機能として、ブーリアン、移動、削除、さらに修正が利用できます。


Create (作成)は、形状を新たに作成したり、既存の形状から作成したりする機能です。


 

Modify (編集・修正・修復)は、既存の形状を編集や微修正を行ったり、壊れた形状を修復する機能です。修復は、特に他のCADから形状を読み込んだ場合に形状が壊れているときに利用します。修復機能で形状が修復できない場合は、元のCADから互換性の良い型式で出力したり、場合によっては、元のCADで修正を行う必要があります。


 

Boolean (ブーリアン)は、形状を足し算したり、引き算すしたり、掛け算(共通部分)を行う機能です。一般的に、和、差、積と言われます。この他、Cubitには、ブーリアン系のコマンドとして、Imprint/MergeやWebcutが利用できます。Imprintは、交線を求める機能、Mergeは、同じ形の形状が同じ場所にあった場合に連結する機能です。Webcutはサーフェースやボリューム、ボディなどで既存の形状を分割する機能です


 

Translate (座標変換)は、形状を移動、回転、反転、スケーリングする機能です。


 

Delete (削除)は、形状を削除する機能です。Cubitでは、下位のジオメトリを残して削除することが可能です。


 

Webcut (形状分割)は、形状を分割する機能です。ヘキサメッシュ作成に先立ち、Webcut機能で、ヘキサメッシュ可能な形状に分割していきます。ヘキサメッシュ作成に必要な作業は、この分割作業に尽きます。ヘキサメッシュを作成するために行うべき作業は、ManyToManyタイプの形状をManyToOneまたは、OneToOneに分割するだけです。Cubitでは、この作業のために便利なWebcutツールを提供しております。


 

Virtual Geometry (バーチャルジオメトリ)は、CADのSolidモデリング機能(Real Geometry)では、対応できない、面の合成や面の分割をする機能です。一般的にCADでは、連続性のある面しか合成できません。また、CADは、メッシュを作成することを意識して開発しておらず、実際の物体の表面を表現するために、複数の数学的に定義可能な連続な面に分けて物体の表面を表現します。このように複数に分けて定義されたサーフェースに対して、ユーザーが希望するメッシュを作成することができない場合があります。CubitのVirtual Geometry機能を利用すると、CAD機能で合成できない数学的に連続性のない面を仮想的に合成することができます。