Hexa Meshで歪み角度の悪い要素を自動修正する方法

カテゴリー作成日/修正日2016/6/52016/6/5対応Trelisバージョン16.0.0 → 16.0.2カテゴリーGeometry→ Surface → CreateGUIMesh→Volume→Clean up hex elementTUIcleanup volume <id>sキーワード歪み角度,自動修正Key WordMesh,Skew,Clean upHexa Meshで歪み角度の悪い要素を自動修正する方法(Mesh-Clean-up-Hexa)Trelisでバージョン16以降からHexa...

Trelis起動時にコマンドを自動実行する方法

カテゴリー作成日/修正日2016/2/22016/2/2対応Trelisバージョン15.0.1 → 15.2.0カテゴリーOperation→ Auto→ CommandGUINOTUINOキーワード起動,コマンド,自動,実行Key WordCommand,Auto,PlayTrelis起動時にコマンドを自動実行する方法について(Auto-Run-Command)Trelisで起動時にDefaultで設定されているOption...

Surfaceの面積を計算する方法

カテゴリー 作成日/修正日 2015/8/23 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4 カテゴリー Calculate→Surface→Area GUI Properties Page→Geometry→Surface Area→Calc TUI list surface <id> geometry キーワード 計算,面積 Key Word Calculate,Surface,Area...

上下の半径と高さを指定して円錐台を作成する方法

カテゴリー 作成日/修正日 2015/9/13 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Geometry→Surface→Create GUI Geometry→Volumes→Create→Cone TUI create frustum height <#> radius <#> top <#> キーワード 円錐台 Key Word Frustum,Radius...

Volume-MeshのSurfaceを指定して近傍を細分化する方法

カテゴリー 作成日/修正日 2015/10/5 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4 カテゴリー Mesh→Volume→Refinement→Surface GUI NO TUI refine surface <id> size <#> bias <#> smooth キーワード メッシュ,細分化,面,指定 Key Word Mesh ,Refinement,Volume,Surface...

Curveのライン上に比率でVertexを作成する方法

カテゴリー作成日/修正日2016/6/72016/6/7対応Trelisバージョン15.0.0 → 16.0.2カテゴリーGeometry→ Vertex→ CreateGUIGeometry→Vertex→Create→On CurveTUIcreate vertex on curve <id> fraction <#> from startキーワードカーブ,頂点,作成,比率Key WordOn...

分割された面の形状を結合して簡素化する方法

カテゴリー 作成日/修正日 2015/9/5 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Geometry→Surface→Modify GUI Geometry→Surfaces→Modify→Regularize TUI regularize surface <id>s キーワード 簡素化,結合 Key Word Regularize,Simplify 分割された面の形状を結合して簡素化する方法について(Regularize)...

NodesetでFEA境界のForceを設定する方法

カテゴリー 作成日/修正日 2016/7/20 2016/7/20 対応Trelisバージョン 15.0.0 → 16.0.3 カテゴリー BC→ FEA→ Force GUI FEA BCs→ Force→ Create TUI create force キーワード 構造解析,境界設定 Key Word FEA,BC,Force NodesetでFEA境界のForceを設定する方法について(BC-Nodeset-FEA-Force)...

Undoで操作を元に戻す方法

カテゴリー 作成日/修正日 2015/9/8 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Operation→Basic→Undo GUI Tool bars→undo TUI undo キーワード 元に戻す,やり直し Key Word Undo Undoで操作を元に戻す方法について(Undo) TRELIS では形状作成機能については やり直し操作Undoを行うことが出来ます.UndoはTool...

円形状面に放射状の四角形メッシュを作成する方法

カテゴリー 作成日/修正日 2015/9/19 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Mesh→Surface→Create GUI Mesh→Surface→Scheme→Circle TUI surface <id> scheme circle interval <#> fraction <#> キーワード メッシュ,円,スキーム Key Word Mesh,Scheme,Circle...

最新のドキュメント

二面間の角度を測量する方法

二面間の角度を測量する方法

カテゴリー 作成日/修正日 2017/3/22 2017/3/22 対応Trelisバージョン 16.2.2 → 16.3.0 カテゴリー Measure→Surface→ Angle GUI Measure→Surface→ Angle TUI measure angle direction surface <id> with direction surface <id> キーワード 面,方向,角度 Key Word Surface,Direction,Angle...

二直線間の角度を測量する方法

二直線間の角度を測量する方法

カテゴリー 作成日/修正日 2017/3/22 2017/3/22 対応Trelisバージョン 16.2.2 → 16.3.0 カテゴリー Measure→Curve→ Angle GUI Measure→Curve→ Angle TUI measure angle direction curve <id> with direction curve <id> キーワード 直線,方向,角度 Key Word Curve,Direction,Angle...

指定したVolume内のElementのID番号を変更する方法

カテゴリー 作成日/修正日 2017/3/19 2017/3/19 対応Trelisバージョン 15.0.0 → 16.3.0 カテゴリー Mesh→Element→ Modify GUI Mesh→Volume→ Renumber TUI renumber face all in volume <id> start_id 1 uniqueids キーワード ボリューム,要素,番号,変更 Key Word Mesh,Volume,Element ID,Renumber...

指定したVolume内のNodeのID番号を変更する方法

カテゴリー 作成日/修正日 2017/3/19 2017/3/19 対応Trelisバージョン 15.0.0 → 16.3.0 カテゴリー Mesh→Node→ Modify GUI Mesh→Volume→ Renumber TUI renumber node all in volume <id> start_id 1 uniqueids キーワード ボリューム,ノード,接点,番号,変更 Key Word Mesh,Volume,Node ID,Renumber...

指定したSurface上のElementのID番号を変更する方法

カテゴリー 作成日/修正日 2017/3/17 2017/3/17 対応Trelisバージョン 15.0.0 → 16.3.1 カテゴリー Mesh→Element→ Modify GUI Mesh→Surface→ Renumber TUI renumber face all in surface <id> start_id <#> uniqueids キーワード 面,要素,接点,番号,変更 Key Word Mesh,Surface,Element ID,Renumber...

指定したElementのID番号を変更する方法

カテゴリー 作成日/修正日 2017/3/18 2017/3/18 対応Trelisバージョン 15.0.0 → 16.0.3 カテゴリー Mesh→Element→ Modify GUI Mesh→Face→ Renumber  TUI renumber face <#> start_id <#> uniqueids キーワード 要素,接点,番号,変更 Key Word Mesh,Element ID,Renumber...

指定したEdgeのID番号を変更する方法

カテゴリー 作成日/修正日 2017/3/18 2017/3/18 対応Trelisバージョン 15.0.0 → 16.0.3 カテゴリー Mesh→Edge→ Modify GUI Mesh→Edges→ Renumber TUI renumber edge <#> start_id <#> uniqueids キーワード エッジ,接点,番号,変更 Key Word Mesh,Edge ID,Renumber 指定したEdgeのID番号を変更する方法(Mesh_Renumber_Edge_ID)...

機能別チュートリアル一覧

絵を描くには、たった5つの操作を理解するだけでOKです。基本的には、作成だけでできますが、便利な機能として、ブーリアン、移動、削除、さらに修正が利用できます。


Create (作成)は、形状を新たに作成したり、既存の形状から作成したりする機能です。


 

Modify (編集・修正・修復)は、既存の形状を編集や微修正を行ったり、壊れた形状を修復する機能です。修復は、特に他のCADから形状を読み込んだ場合に形状が壊れているときに利用します。修復機能で形状が修復できない場合は、元のCADから互換性の良い型式で出力したり、場合によっては、元のCADで修正を行う必要があります。


 

Boolean (ブーリアン)は、形状を足し算したり、引き算すしたり、掛け算(共通部分)を行う機能です。一般的に、和、差、積と言われます。この他、Cubitには、ブーリアン系のコマンドとして、Imprint/MergeやWebcutが利用できます。Imprintは、交線を求める機能、Mergeは、同じ形の形状が同じ場所にあった場合に連結する機能です。Webcutはサーフェースやボリューム、ボディなどで既存の形状を分割する機能です


 

Translate (座標変換)は、形状を移動、回転、反転、スケーリングする機能です。


 

Delete (削除)は、形状を削除する機能です。Cubitでは、下位のジオメトリを残して削除することが可能です。


 

Webcut (形状分割)は、形状を分割する機能です。ヘキサメッシュ作成に先立ち、Webcut機能で、ヘキサメッシュ可能な形状に分割していきます。ヘキサメッシュ作成に必要な作業は、この分割作業に尽きます。ヘキサメッシュを作成するために行うべき作業は、ManyToManyタイプの形状をManyToOneまたは、OneToOneに分割するだけです。Cubitでは、この作業のために便利なWebcutツールを提供しております。


 

Virtual Geometry (バーチャルジオメトリ)は、CADのSolidモデリング機能(Real Geometry)では、対応できない、面の合成や面の分割をする機能です。一般的にCADでは、連続性のある面しか合成できません。また、CADは、メッシュを作成することを意識して開発しておらず、実際の物体の表面を表現するために、複数の数学的に定義可能な連続な面に分けて物体の表面を表現します。このように複数に分けて定義されたサーフェースに対して、ユーザーが希望するメッシュを作成することができない場合があります。CubitのVirtual Geometry機能を利用すると、CAD機能で合成できない数学的に連続性のない面を仮想的に合成することができます。