指定したVolume内のNodeのID番号を変更する方法

カテゴリー 作成日/修正日 2017/3/19 2017/3/19 対応Trelisバージョン 15.0.0 → 16.3.0 カテゴリー Mesh→Node→ Modify GUI Mesh→Volume→ Renumber TUI renumber node all in volume <id> start_id 1 uniqueids キーワード ボリューム,ノード,接点,番号,変更 Key Word Mesh,Volume,Node ID,Renumber...

Curveの方向を変える方法(Geometry→Modify→Curve→Sense)

Curveの方向を変える方法 (Geometry→Modify→Curve→Sense) カテゴリー 作成日/修正日 2015/08/01 2024/10/20 対応cubitバージョン 16.3.0→2024.8 カテゴリー Geometry-→Curve→Modify GUI Geometry-→Modify →Curves→Sense TUI curve <id> tangent opposite キーワード カーブ,方向,変更 Key Word Curve,Direction,Modify,...

Volumeの体積を計算する方法

カテゴリー 作成日/修正日 2015/8/21 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4 カテゴリー Calculate→Volume→Volume GUI Properties Page→Geometry→Volume→Calc TUI list volume <id> geometry キーワード 計算,体積 Key Word Calculate, Volume Volumeの体積の計算方法について(Calculate-Volume)...

Viewカメラの位置を座標値で設定する方法

カテゴリー作成日/修正日2016/3/302016/3/30対応Trelisバージョン15.0.1 → 16.0.0カテゴリーDisplay → View → CameraGUINOTUIAt <#,#,#> From <#,#,#> Up<#,#,#>キーワードビュー,カメラ,視点,位置Key...

Trelisのコマンドパネルのボタン構成と主な機能

カテゴリー 作成日/修正日 2015/10/20 2015/11/3 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Operation→Basic→GUI→Command Panel GUI Command Panel TUI NO キーワード コマンドパネル,構成,機能 Key Word Command,Panel,Distribution,Function Trelisのコマンドパネルのボタン構成と主な機能について(Command-Panel)...

形状のEntityをそれぞれマウスで選択する方法

カテゴリー 作成日/修正日 2015/10/30 2015/11/3 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Display → Geometry → Entity-Selection GUI View → Toolbars → Select Geometry Tools TUI Pick <entities> キーワード 形状,選択,マウス,クリック Key Word Geometry,Selection,Entity,Mouse,Pick...

外部境界となるSurfaceを自動で見つけてグループ化する方法

カテゴリー作成日/修正日2016/7/142016/7/14対応Trelisバージョン15.0.0 → 16.0.2カテゴリーGroup→ Surface→BCGUINOTUIgroup "<$$$>" equals surface with not is_mergedキーワードグループ,面,境界,解放面,抽出Key...

分割した複数のEntityを自動で関連した名前にする方法

カテゴリー 作成日/修正日 2015/11/10 2015/11/10 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5,15.1.6 カテゴリー Operation → Entity → Name GUI NO TUI NO キーワード エンティティ,名前,分割,関連 Key Word Entity,Name,Webcut,Split,Propagation 分割した複数のEntityを自動で関連した名前にする方法について(Entity-Propagation-Name)...

画面のViewを画像ファイルに出力する方法

カテゴリー作成日/修正日2016/4/52016/4/5対応Trelisバージョン15.0.1 → 16.0.0カテゴリーDisplay → View → HardcopyGUINOTUIhardcopy "File_name" <jpg,png,bmp,tiff,eps>キーワードビュー,ハードコピー,画像,ファイルKey WordView,Hardcopy,Graphic,Window画面のViewを画像ファイルに出力する方法(Display-View-Hardcopy)TrelisでGraphic...

共有面がずれたBodyを誤差を指定して結合させる方法

カテゴリー作成日/修正日2016/2/272016/2/27対応Trelisバージョン15.0.1 → 15.2.0カテゴリーGeometry→ Volume→ ModifyGUIGeometry→Volume→Imprint and Merge→MergeTUImerge tolerance <#>キーワード結合,誤差,許容誤差Key...

最新のドキュメント

Volume-MeshのVertexを指定して近傍を細分化する方法

Volume-MeshのVertexを指定して近傍を細分化する方法

カテゴリー 作成日/修正日 2015/10/4 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4 カテゴリー Mesh→Volume→Refinement→Vertex GUI NO TUI refine vertex <id> size <#> bias <#> smooth キーワード ボリューム,メッシュ,細分化,頂点,接点 Key Word Volume,Mesh ,Refinement, Vertex...

Surface-MeshのVertexを指定して近傍を細分化する方法

Surface-MeshのVertexを指定して近傍を細分化する方法

カテゴリー 作成日/修正日 2015/10/4 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4 カテゴリー Mesh→Surface→Refinement→Vertex GUI NO TUI refine vertex <id> size <#> bias <#> smooth キーワード 面,メッシュ,細分化,頂点,接点 Key Word Surface,Mesh ,Refinement,Vertex...

隣接する六面体Meshの片方だけ細分化する方法

隣接する六面体Meshの片方だけ細分化する方法

カテゴリー 作成日/修正日 2015/10/4 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4 カテゴリー Mesh→Volume→Refinement→Structure Subdivision GUI NO TUI refine volume <id> using surface <id> キーワード 六面体,隣接、構造メッシュ、細分化 Key Word Mesh ,Refinement,Subdivision、Hexahedral...

ジャーナルファイルで数学定数を利用する方法

カテゴリー 作成日/修正日 2015/10/1 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Journal→Constant→Mathematical GUI NO TUI CONSTANT キーワード ジャーナル,ファイル,変数,数学,定数 Key Word Journal,File,Variables,Mathematical,Constant ジャーナルファイルで数学定数を利用する方法について(Journal-Constant)...

ジャーナルファイルで変数の値を表示する方法

カテゴリー 作成日/修正日 2015/10/1 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Journal→Command→Comment GUI NO TUI Comment <variables> キーワード ジャーナル,ファイル,変数,値,表示 Key Word Journal,File,Variables,Display ジャーナルファイルで変数の値を表示する方法について(Journal-Comment)...

ジャーナルファイルでLoopステートメントを使う方法

ジャーナルファイルでLoopステートメントを使う方法

カテゴリー 作成日/修正日 2015/9/30 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Journal→Statement→Loop GUI NO TUI {Loop(Control)},{EndLoop} キーワード ジャーナル,ファイル,繰り返し文 Key Word Journal,File,Loop,statement ジャーナルファイルでLoopステートメントを使う方法について(Journal-Loop)...

機能別チュートリアル一覧

絵を描くには、たった5つの操作を理解するだけでOKです。基本的には、作成だけでできますが、便利な機能として、ブーリアン、移動、削除、さらに修正が利用できます。


Create (作成)は、形状を新たに作成したり、既存の形状から作成したりする機能です。


 

Modify (編集・修正・修復)は、既存の形状を編集や微修正を行ったり、壊れた形状を修復する機能です。修復は、特に他のCADから形状を読み込んだ場合に形状が壊れているときに利用します。修復機能で形状が修復できない場合は、元のCADから互換性の良い型式で出力したり、場合によっては、元のCADで修正を行う必要があります。


 

Boolean (ブーリアン)は、形状を足し算したり、引き算すしたり、掛け算(共通部分)を行う機能です。一般的に、和、差、積と言われます。この他、Cubitには、ブーリアン系のコマンドとして、Imprint/MergeやWebcutが利用できます。Imprintは、交線を求める機能、Mergeは、同じ形の形状が同じ場所にあった場合に連結する機能です。Webcutはサーフェースやボリューム、ボディなどで既存の形状を分割する機能です


 

Translate (座標変換)は、形状を移動、回転、反転、スケーリングする機能です。


 

Delete (削除)は、形状を削除する機能です。Cubitでは、下位のジオメトリを残して削除することが可能です。


 

Webcut (形状分割)は、形状を分割する機能です。ヘキサメッシュ作成に先立ち、Webcut機能で、ヘキサメッシュ可能な形状に分割していきます。ヘキサメッシュ作成に必要な作業は、この分割作業に尽きます。ヘキサメッシュを作成するために行うべき作業は、ManyToManyタイプの形状をManyToOneまたは、OneToOneに分割するだけです。Cubitでは、この作業のために便利なWebcutツールを提供しております。


 

Virtual Geometry (バーチャルジオメトリ)は、CADのSolidモデリング機能(Real Geometry)では、対応できない、面の合成や面の分割をする機能です。一般的にCADでは、連続性のある面しか合成できません。また、CADは、メッシュを作成することを意識して開発しておらず、実際の物体の表面を表現するために、複数の数学的に定義可能な連続な面に分けて物体の表面を表現します。このように複数に分けて定義されたサーフェースに対して、ユーザーが希望するメッシュを作成することができない場合があります。CubitのVirtual Geometry機能を利用すると、CAD機能で合成できない数学的に連続性のない面を仮想的に合成することができます。