Vertexを面の法線方向にSweepして直線を作成する方法

カテゴリー 作成日/修正日 2015/9/5 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Geometry→Curve→Create GUI Geometry→Curves→Create→Line→Location and Direction TUI create curve location at vertex <id> direction surface <id> length <#> キーワード...

FLUENT形式の出力でZoneの名前を変更する方法

カテゴリー 作成日/修正日 2015/8/26 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4 カテゴリー BC→Block→Name GUI Power Tool→Blocks TUI block <id> name "$$$" キーワード ブロック,セル,ゾーン、名前 Key Word Block,Cell.Zone、Name FLUENT形式の出力でZoneの名前を変更する方法について(Block-Name)...

半径と高さを指定して円錐を作成する方法

カテゴリー 作成日/修正日 2015/9/12 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Geometry→Surface→Create GUI Geometry→Volumes→Create→Cone TUI create frustum height <#> radius <#> top 0 キーワード 円錐 Key Word Cone,Frustum,Radius...

2つの Vertex 間の距離を計算する方法

カテゴリー 作成日/修正日 2015/9/1 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4 カテゴリー Calculate→Vertex→Distance GUI Graphic Window TUI measure between vertex <id> vertex <id> キーワード 距離,2点間 Key Word Vertex,Distance 2つの Vertex 間の距離を計算する方法について(Calculate-Vertex)...

Surfaceの色を変更する方法

カテゴリー作成日/修正日2016/3/182016/3/18対応Trelisバージョン15.0.1 → 15.2.0カテゴリーSurface→ Modify→ColorGUIGeometry→Surface→Preference →ColorTUIcolor Surface <id>s geometry <colors>キーワード面,色,変更Key...

Curveの近傍を分割回数を指定してメッシュを細分化する方法

カテゴリー作成日/修正日2016/7/242016/7/24対応Trelisバージョン15.0.0 → 16.0.3カテゴリーMesh→ Vertex→ ModifyGUIMesh → Surface → Refine →General RefinementTUIrefine curve <id>s numsplit <#> bias 1 depth 1キーワードメッシュ,細分化,カーブ,分割回数Key WordMesh,Refine,Curve,Number...

結合されたBodyを分割させる方法

カテゴリー作成日/修正日2016/2/262016/2/26対応Trelisバージョン15.0.1 → 15.2.0カテゴリーGeometry→ Volume→ ModifyGUIGeometry→Volume→Imprint and Merge→UnmergeTUIunmerge body <id>sキーワードボリューム,分割,分離Key...

円形状面に放射状の四角形メッシュを作成する方法

カテゴリー 作成日/修正日 2015/9/19 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Mesh→Surface→Create GUI Mesh→Surface→Scheme→Circle TUI surface <id> scheme circle interval <#> fraction <#> キーワード メッシュ,円,スキーム Key Word Mesh,Scheme,Circle...

円の内部に境界層メッシュを作成する方法

カテゴリー 作成日/修正日 2016/12/4 2016/12/4 対応Trelisバージョン 15.0.0 → 16.0.3 カテゴリー Mesh→ Boundary Layer → Create GUI Mesh→ Boundary Layer → Create TUI boundary_layer 1 uniform height <#> growth <#> layers <#> キーワード 境界層,円,カーブ Key Word Boundary Layer,Circle,Curve...

面の法線方向に押し出してVolumeを作成する方法

カテゴリー 作成日/修正日 2016/12/2 2016/12/2 対応Trelisバージョン 15.0.0 → 16.0.3 カテゴリー Geometry→ Volume → Create GUI Geometry→ Volume → Create →Sweep TUI sweep surface <id>s perpendicular distance <#> キーワード 面,押し出し,法線 Key Word Volume,Create,Surface,Sweep...

最新のドキュメント

Volumeメッシュの面を指定して境界層を作成する方法

Volumeメッシュの面を指定して境界層を作成する方法

カテゴリー 作成日/修正日 2015/10/16 2015/11/3 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Mesh→Refine→Pillowing GUI Mesh→Refine→Pillowing TUI pillow hex all through surface all except surface <id> distance <#> unfix_nodes キーワード メッシュ,修正,境界層,面 Key Word...

四角形Meshの面要素を指定して近傍を細分化する方法

四角形Meshの面要素を指定して近傍を細分化する方法

カテゴリー 作成日/修正日 2015/10/16 2015/11/3 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Mesh→Refinement→Face GUI Mesh→Quad→Refine TUI refine face <id> depth <#> smooth キーワード メッシュ,細分化,面要素,四角形,隣接 Key Word Mesh,Refinement,Element,Quad,Depth...

Nodeを指定して近傍を細分化する方法

Nodeを指定して近傍を細分化する方法

カテゴリー 作成日/修正日 2015/10/16 2015/11/3 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Mesh→Refine→Node GUI Mesh→Node→Refine TUI refine node <id> depth <#> smooth キーワード メッシュ,細分化,ノード,近傍 Key Word Mesh,Refine,Node,Depth...

各Blockに設定されているVolumeを変更する方法

各Blockに設定されているVolumeを変更する方法

カテゴリー 作成日/修正日 2015/10/10 2015/11/3 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Group→Block→Modify GUI Group→Block→Add TUI block <id> volume <id>s remove キーワード ブロック,ボリューム,変更 Key Word Block,Volume,Modify...

VolumeまとめてBlockを設定する方法

VolumeまとめてBlockを設定する方法

カテゴリー 作成日/修正日 2015/10/10 2015/11/3 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Group→Block→Create GUI Group→Block→Manage→Add TUI block <id. volume <id>s キーワード ボリューム,ブロック,グループ,作成 Key Word Volume,Block,Group,Create,Add...

Sidesetに設定されているSurfaceを修正する方法

Sidesetに設定されているSurfaceを修正する方法

カテゴリー 作成日/修正日 2015/10/10 2015/11/3 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Group→Sideset→Modify GUI Group→Sideset→Manage TUI sideset <id> surface <id>s remove キーワード 面,サイドセット,グループ,修正,削除 Key Word Surface,Sideset,Add,remove...

SidesetにSurfaceを追加設定する方法

SidesetにSurfaceを追加設定する方法

カテゴリー 作成日/修正日 2015/10/10 2015/11/3 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Group→Sideset→Modify GUI Group→Sideset→Manage→Add TUI sideset <id> surface <id>s キーワード 面,サイドセット,追加 Key Word Surface,Sideset,Add...

SurfaceをまとめてSidesetを設定する方法

SurfaceをまとめてSidesetを設定する方法

カテゴリー 作成日/修正日 2015/10/9 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Group→Sideset→Create GUI Group→Sideset→Manage→Add TUI sideset <id> surface <id>s キーワード 面,サイドセット,グループ,作成 Key Word Surface,Sideset,Create...

機能別チュートリアル一覧

絵を描くには、たった5つの操作を理解するだけでOKです。基本的には、作成だけでできますが、便利な機能として、ブーリアン、移動、削除、さらに修正が利用できます。


Create (作成)は、形状を新たに作成したり、既存の形状から作成したりする機能です。


 

Modify (編集・修正・修復)は、既存の形状を編集や微修正を行ったり、壊れた形状を修復する機能です。修復は、特に他のCADから形状を読み込んだ場合に形状が壊れているときに利用します。修復機能で形状が修復できない場合は、元のCADから互換性の良い型式で出力したり、場合によっては、元のCADで修正を行う必要があります。


 

Boolean (ブーリアン)は、形状を足し算したり、引き算すしたり、掛け算(共通部分)を行う機能です。一般的に、和、差、積と言われます。この他、Cubitには、ブーリアン系のコマンドとして、Imprint/MergeやWebcutが利用できます。Imprintは、交線を求める機能、Mergeは、同じ形の形状が同じ場所にあった場合に連結する機能です。Webcutはサーフェースやボリューム、ボディなどで既存の形状を分割する機能です


 

Translate (座標変換)は、形状を移動、回転、反転、スケーリングする機能です。


 

Delete (削除)は、形状を削除する機能です。Cubitでは、下位のジオメトリを残して削除することが可能です。


 

Webcut (形状分割)は、形状を分割する機能です。ヘキサメッシュ作成に先立ち、Webcut機能で、ヘキサメッシュ可能な形状に分割していきます。ヘキサメッシュ作成に必要な作業は、この分割作業に尽きます。ヘキサメッシュを作成するために行うべき作業は、ManyToManyタイプの形状をManyToOneまたは、OneToOneに分割するだけです。Cubitでは、この作業のために便利なWebcutツールを提供しております。


 

Virtual Geometry (バーチャルジオメトリ)は、CADのSolidモデリング機能(Real Geometry)では、対応できない、面の合成や面の分割をする機能です。一般的にCADでは、連続性のある面しか合成できません。また、CADは、メッシュを作成することを意識して開発しておらず、実際の物体の表面を表現するために、複数の数学的に定義可能な連続な面に分けて物体の表面を表現します。このように複数に分けて定義されたサーフェースに対して、ユーザーが希望するメッシュを作成することができない場合があります。CubitのVirtual Geometry機能を利用すると、CAD機能で合成できない数学的に連続性のない面を仮想的に合成することができます。