Curveの近傍を分割回数を指定してメッシュを細分化する方法

カテゴリー作成日/修正日2016/7/242016/7/24対応Trelisバージョン15.0.0 → 16.0.3カテゴリーMesh→ Vertex→ ModifyGUIMesh → Surface → Refine →General RefinementTUIrefine curve <id>s numsplit <#> bias 1 depth 1キーワードメッシュ,細分化,カーブ,分割回数Key WordMesh,Refine,Curve,Number...

Curve上に始点からのを距離を指定して複数のメッシュNodeを作成する方法

カテゴリー 作成日/修正日 2015/9/14 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Mesh→Curve→Create GUI Mesh→Curves→Attribute→PinPoint TUI curve <id> scheme pinpoint location <#>s キーワード メッシュ,距離,複数,ノード Key Word Mesh,Node,Pinpoint...

Vertexの近傍を分割回数を指定してメッシュを細分化する方法

カテゴリー作成日/修正日2016/7/232016/7/23対応Trelisバージョン15.0.0 → 16.0.3カテゴリーMesh→ Vertex→ ModifyGUIMesh → Surface → Refine →General RefinementTUIrefine vertex <id>s numsplit <#> bias 1 depth 1キーワードメッシュ,細分化,分割回数Key WordMesh,Refine,Number...

Graphic-Windowの背景色を変更する方法

カテゴリー 作成日/修正日 2015/9/7 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Display→Window→Color GUI Tools→Options→Display→Background Color TUI color background <bottom_color> <top_color> キーワード 背景色,変更 Key Word Background,Color...

ジャーナルEditorを利用してコマンドを実行する方法

カテゴリー 作成日/修正日 2015/9/30 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Journal→Editor→Play GUI Toolbar→Journal Editor TUI キーワード ジャーナル,エディター,1ライン Key Word Journal,Editor,Line,Command ジャーナルEditorを利用してコマンドを実行する方法について(Journal-Editor)...

面ベクトルを反転させる方法

カテゴリー 作成日/修正日 2015/8/31 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4 カテゴリー Geometry→Surface→Modify GUI Geometry→Surface→Modify→Reverse Normal TUI reverse surface <id> キーワード 面,方向,反転 Key Word Surface,Reverse,Normal,Vector 面ベクトルを反転させる方法について(Reverse-Normal)...

表示されているViewの位置情報を取得する方法(View-Get-Position)

カテゴリー作成日/修正日2016/4/42016/4/4対応Trelisバージョン15.0.1 → 16.0.0カテゴリーDisplay → View → RotateGUINOTUIview list,view journalキーワードビュー,座標値,情報,取得Key WordView,Get,Position,List,Journal表示されているViewの位置情報を取得する方法について(View-Get-Position)TrelisのGraphic...

Nodeを指定して近傍を細分化する方法

カテゴリー 作成日/修正日 2015/10/16 2015/11/3 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Mesh→Refine→Node GUI Mesh→Node→Refine TUI refine node <id> depth <#> smooth キーワード メッシュ,細分化,ノード,近傍 Key Word Mesh,Refine,Node,Depth...

Trelisの形状についての構成要素Entityの概念

カテゴリー 作成日/修正日 2015/10/21 2015/11/3 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Geometry→Identity→Entity GUI Power Tool→Geometry Tree TUI NO キーワード 形状,構成要素 Key Word Geometry,Entity Trelisの形状についての構成要素Entityの概念について(Geometry-Entity)...

Nodeを面の法線方向に移動させる方法

カテゴリー 作成日/修正日 2015/11/5 2015/11/5 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Mesh → Node → Modify GUI Mesh →Node → Move Node → Surface to Normal TUI node <id> move normal to surface <id> distance <#> キーワード ノード,移動,面,法線,距離 Key Word...

最新のドキュメント

Trelisの形状についての構成要素Entityの概念

Trelisの形状についての構成要素Entityの概念

カテゴリー 作成日/修正日 2015/10/21 2015/11/3 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Geometry→Identity→Entity GUI Power Tool→Geometry Tree TUI NO キーワード 形状,構成要素 Key Word Geometry,Entity Trelisの形状についての構成要素Entityの概念について(Geometry-Entity)...

多数の立体形状の共有部を抽出する方法

多数の立体形状の共有部を抽出する方法

カテゴリー 作成日/修正日 2015/10/21 2015/11/3 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Geometry→Volume→Modify GUI Geometry→Volume→Boolean→Intersect TUI Intersect body <id>s キーワード ボリューム,ブーリアン,共有部,抽出 Key Word Volume,Boolean,Intersect...

多数の立体形状を一つの形状に合成する方法

多数の立体形状を一つの形状に合成する方法

カテゴリー 作成日/修正日 2015/10/21 2015/11/3 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Geometry→Volume→Modify GUI Geometry→Volume→Boolean→Unite TUI unite body <id>s キーワード ボリューム,ブーリアン,合成 Key Word Volume,Boolean,Unite 多数の立体形状を一つの形状に合成する方法について(Boolean-Unite)...

Volumeメッシュの内部メッシュを断面で確認する方法

カテゴリー 作成日/修正日 2015/10/21 2015/10/26 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Mesh→Visual→Inside GUI Toolbar→Toggle Clipping Plane TUI NO キーワード メッシュ,内部,表示,トグル Key Word Mesh,Inside,Toggle Volumeメッシュの内部メッシュを断面で確認する方法について(Toggle-Clipping-Plane)...

Trelisのコマンドパネルのボタン構成と主な機能

カテゴリー 作成日/修正日 2015/10/20 2015/11/3 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Operation→Basic→GUI→Command Panel GUI Command Panel TUI NO キーワード コマンドパネル,構成,機能 Key Word Command,Panel,Distribution,Function Trelisのコマンドパネルのボタン構成と主な機能について(Command-Panel)...

立体形状を他の立体で切り抜く方法

立体形状を他の立体で切り抜く方法

カテゴリー 作成日/修正日 2015/10/20 2015/11/3 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Geometry→Volume→Modify GUI Geometry→Volume→Boolean→Subtract TUI subtract body <id>s from body <id> キーワード ボディー,ブーリアン,切り抜き Key Word Body,Boolean,Subtract...

TrelisのGUIパネルの名称と主な機能

カテゴリー 作成日/修正日 2015/10/20 2015/11/3 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Operation→Basic→GUI GUI GUI→Panel TUI NO キーワード パネル,名称,機能 Key Word GUI,Panel TrelisのGUIパネルの名称と主な機能について(GUI-Panel)...

機能別チュートリアル一覧

絵を描くには、たった5つの操作を理解するだけでOKです。基本的には、作成だけでできますが、便利な機能として、ブーリアン、移動、削除、さらに修正が利用できます。


Create (作成)は、形状を新たに作成したり、既存の形状から作成したりする機能です。


 

Modify (編集・修正・修復)は、既存の形状を編集や微修正を行ったり、壊れた形状を修復する機能です。修復は、特に他のCADから形状を読み込んだ場合に形状が壊れているときに利用します。修復機能で形状が修復できない場合は、元のCADから互換性の良い型式で出力したり、場合によっては、元のCADで修正を行う必要があります。


 

Boolean (ブーリアン)は、形状を足し算したり、引き算すしたり、掛け算(共通部分)を行う機能です。一般的に、和、差、積と言われます。この他、Cubitには、ブーリアン系のコマンドとして、Imprint/MergeやWebcutが利用できます。Imprintは、交線を求める機能、Mergeは、同じ形の形状が同じ場所にあった場合に連結する機能です。Webcutはサーフェースやボリューム、ボディなどで既存の形状を分割する機能です


 

Translate (座標変換)は、形状を移動、回転、反転、スケーリングする機能です。


 

Delete (削除)は、形状を削除する機能です。Cubitでは、下位のジオメトリを残して削除することが可能です。


 

Webcut (形状分割)は、形状を分割する機能です。ヘキサメッシュ作成に先立ち、Webcut機能で、ヘキサメッシュ可能な形状に分割していきます。ヘキサメッシュ作成に必要な作業は、この分割作業に尽きます。ヘキサメッシュを作成するために行うべき作業は、ManyToManyタイプの形状をManyToOneまたは、OneToOneに分割するだけです。Cubitでは、この作業のために便利なWebcutツールを提供しております。


 

Virtual Geometry (バーチャルジオメトリ)は、CADのSolidモデリング機能(Real Geometry)では、対応できない、面の合成や面の分割をする機能です。一般的にCADでは、連続性のある面しか合成できません。また、CADは、メッシュを作成することを意識して開発しておらず、実際の物体の表面を表現するために、複数の数学的に定義可能な連続な面に分けて物体の表面を表現します。このように複数に分けて定義されたサーフェースに対して、ユーザーが希望するメッシュを作成することができない場合があります。CubitのVirtual Geometry機能を利用すると、CAD機能で合成できない数学的に連続性のない面を仮想的に合成することができます。