中心と1点を通る円Surfaceを作成する方法

カテゴリー 作成日/修正日 2015/09/10 2015/11/04 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Geometry→Surface→Create GUI Geometry→Surfaces→Create→Circle→Center Vertex TUI create surface circle center vertex <id> <id> <id> キーワード 円,1点,面、中心 Key Word...

Viewの拡大・縮小をコマンド(TUI)で表示する方法

カテゴリー作成日/修正日2016/4/52016/4/5対応Trelisバージョン15.0.1 → 16.0.0カテゴリーDisplay → View → ZoomGUINOTUIzoom screen <#>キーワードビュー,拡大,縮小,アニメーションKey...

Entityに固有の名前をつける方法

カテゴリー 作成日/修正日 2015/11/9 2015/11/9 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5,15.1.6 カテゴリー Operation → Entity → Name GUI Power Tool → Geometry tree TUI <$> name "<$>",<$> rename "<$>" キーワード エンティティ,名前,変更 Key Word...

Volume-Meshの各要素をN分割して細分化する方法

カテゴリー 作成日/修正日 2015/10/6 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4 カテゴリー Mesh→Volume→Refine→Split GUI Mesh→Volume→Refine→General Refinement→Split TUI refine volume <id> numsplit <#> smooth キーワード メッシュ,ボリューム,細分化,半分 Key Word Mesh , Volume,...

座標点と方向・長さを指定して直線Lineを作成する方法

カテゴリー 作成日/修正日 2015/9/9 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Geometry→Curve→Create GUI Geometry→Curves→Create→Line→Location and Direction TUI create curve location <#> <#> <#> direction <#> <#> <#> length...

半径と高さを指定して円錐を作成する方法

カテゴリー 作成日/修正日 2015/9/12 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Geometry→Surface→Create GUI Geometry→Volumes→Create→Cone TUI create frustum height <#> radius <#> top 0 キーワード 円錐 Key Word Cone,Frustum,Radius...

VolumeのID番号を変更する方法

カテゴリー 作成日/修正日 2015/8/21 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4 カテゴリー Identity→Volume→Modify GUI NO TUI Volume <old_id> id <new_id> キーワード 識別,変更,ボリューム Key Word Identity,Modify,Volume VolumeのID番号を変更する方法について(Volume-ID)...

非構造四角形メッシュPave を作成する方法

カテゴリー 作成日/修正日 2015/9/1 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4 カテゴリー Mesh→Surface→Create GUI Mesh→Surfaces→Schemes→Pave TUI surface <id> scheme pave キーワード ペーブ、スキーム。メッシュ、非構造、四角形 Key Word Scheme、Pave、Mesh 非構造四角形メッシュPave を作成する方法について(Scheme-Pave)...

Surface-MeshのVertexを指定して近傍を細分化する方法

カテゴリー 作成日/修正日 2015/10/4 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4 カテゴリー Mesh→Surface→Refinement→Vertex GUI NO TUI refine vertex <id> size <#> bias <#> smooth キーワード 面,メッシュ,細分化,頂点,接点 Key Word Surface,Mesh ,Refinement,Vertex...

Volumeメッシュの面を指定して境界層を作成する方法

カテゴリー 作成日/修正日 2015/10/16 2015/11/3 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Mesh→Refine→Pillowing GUI Mesh→Refine→Pillowing TUI pillow hex all through surface all except surface <id> distance <#> unfix_nodes キーワード メッシュ,修正,境界層,面 Key Word...

最新のドキュメント

複数の Vertex から Surface を作成する方法

複数の Vertex から Surface を作成する方法

カテゴリー 作成日/修正日 2015/9/5 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Geometry→Surface→Create GUI Geometry→Surfaces→Create→Vertex List TUI create surface vertex <id>s キーワード 面,作成,節点 Key Word Surface,Vertex 複数の Vertex から Surface...

分割された面の形状を結合して簡素化する方法

分割された面の形状を結合して簡素化する方法

カテゴリー 作成日/修正日 2015/9/5 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Geometry→Surface→Modify GUI Geometry→Surfaces→Modify→Regularize TUI regularize surface <id>s キーワード 簡素化,結合 Key Word Regularize,Simplify 分割された面の形状を結合して簡素化する方法について(Regularize)...

複数のCurveをRealに繋げる方法

複数のCurveをRealに繋げる方法

カテゴリー 作成日/修正日 2015/9/5 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Geometry→Curve→Create GUI Geometry→Curves→Create→Combine TUI create curve combine curve <ids> delete キーワード 結合,繋げる,カーブ,直線 Key Word Regularize,Combine...

正多角形平面を作成する方法

正多角形平面を作成する方法

カテゴリー 作成日/修正日 2015/9/4 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Geometry→Surface→Create GUI Geometry→Surfaces→Create→Rectangle TUI create surface rectangle width <#> height <#> zplane キーワード 正多面体,正三角形,正方形 Key Word Regular,Polygon...

平面を2点のVertexで分割する方法

平面を2点のVertexで分割する方法

カテゴリー 作成日/修正日 2015/9/4 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Geometry→Surface→Modify GUI Geometry→Surfaces→Modify→Split TUI split surface <id> through vertex <id> <id> キーワード 分割,点、平面 Key Word Vertex,Split,Surface...

Curve をVertexで分割する方法

Curve をVertexで分割する方法

カテゴリー 作成日/修正日 2015/9/4 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Geometry→Curve→Modify GUI Geometry→Curves→Modify→Split TUI split curve <id> at vertex <id> キーワード 分割,点 Key Word Vertex Curve をVertexで分割する方法について(Split-Vertex)...

Curve を長さの比率を指定して分割する方法

Curve を長さの比率を指定して分割する方法

カテゴリー 作成日/修正日 2015/9/4 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Geometry→Curve→Modify GUI Geometry→Curves→Modify→Split TUI split curve <id> fraction <#> from vertex <id> キーワード 比率,分割,端点 Key Word Vertex,Split,Curve,Fraction...

Curve を端点となる Vertex からの距離を指定して分割する方法

Curve を端点となる Vertex からの距離を指定して分割する方法

カテゴリー 作成日/修正日 2015/9/3 2015/11/4 対応Cubitバージョン 1501, 1504, 1512,1514,1515 カテゴリー Geometry→Curve→Modify GUI Geometry→Curves→Modify→Split TUI split curve <id> distance <#> from vertex <id> キーワード 距離,分割,端点 Key Word Vertex,Split,Curve Curve を端点となる Vertex...

機能別チュートリアル一覧

絵を描くには、たった5つの操作を理解するだけでOKです。基本的には、作成だけでできますが、便利な機能として、ブーリアン、移動、削除、さらに修正が利用できます。


Create (作成)は、形状を新たに作成したり、既存の形状から作成したりする機能です。


 

Modify (編集・修正・修復)は、既存の形状を編集や微修正を行ったり、壊れた形状を修復する機能です。修復は、特に他のCADから形状を読み込んだ場合に形状が壊れているときに利用します。修復機能で形状が修復できない場合は、元のCADから互換性の良い型式で出力したり、場合によっては、元のCADで修正を行う必要があります。


 

Boolean (ブーリアン)は、形状を足し算したり、引き算すしたり、掛け算(共通部分)を行う機能です。一般的に、和、差、積と言われます。この他、Cubitには、ブーリアン系のコマンドとして、Imprint/MergeやWebcutが利用できます。Imprintは、交線を求める機能、Mergeは、同じ形の形状が同じ場所にあった場合に連結する機能です。Webcutはサーフェースやボリューム、ボディなどで既存の形状を分割する機能です


 

Translate (座標変換)は、形状を移動、回転、反転、スケーリングする機能です。


 

Delete (削除)は、形状を削除する機能です。Cubitでは、下位のジオメトリを残して削除することが可能です。


 

Webcut (形状分割)は、形状を分割する機能です。ヘキサメッシュ作成に先立ち、Webcut機能で、ヘキサメッシュ可能な形状に分割していきます。ヘキサメッシュ作成に必要な作業は、この分割作業に尽きます。ヘキサメッシュを作成するために行うべき作業は、ManyToManyタイプの形状をManyToOneまたは、OneToOneに分割するだけです。Cubitでは、この作業のために便利なWebcutツールを提供しております。


 

Virtual Geometry (バーチャルジオメトリ)は、CADのSolidモデリング機能(Real Geometry)では、対応できない、面の合成や面の分割をする機能です。一般的にCADでは、連続性のある面しか合成できません。また、CADは、メッシュを作成することを意識して開発しておらず、実際の物体の表面を表現するために、複数の数学的に定義可能な連続な面に分けて物体の表面を表現します。このように複数に分けて定義されたサーフェースに対して、ユーザーが希望するメッシュを作成することができない場合があります。CubitのVirtual Geometry機能を利用すると、CAD機能で合成できない数学的に連続性のない面を仮想的に合成することができます。