指定したVolume内のNodeのID番号を変更する方法

カテゴリー 作成日/修正日 2017/3/19 2017/3/19 対応Trelisバージョン 15.0.0 → 16.3.0 カテゴリー Mesh→Node→ Modify GUI Mesh→Volume→ Renumber TUI renumber node all in volume <id> start_id 1 uniqueids キーワード ボリューム,ノード,接点,番号,変更 Key Word Mesh,Volume,Node ID,Renumber...

中心点と半径を指定して円Curveを作成する方法

カテゴリー 作成日/修正日 2015/9/9 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Geometry→Curve→Create GUI Geometry→Curves→Create→Arc or Circle→Center Angle TUI create curve arc radius <#> center location <#> <#> <#> normal <#>...

SidesetにSurfaceを追加設定する方法

カテゴリー 作成日/修正日 2015/10/10 2015/11/3 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Group→Sideset→Modify GUI Group→Sideset→Manage→Add TUI sideset <id> surface <id>s キーワード 面,サイドセット,追加 Key Word Surface,Sideset,Add...

ジャーナルファイルでLoopステートメントを使う方法

カテゴリー 作成日/修正日 2015/9/30 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Journal→Statement→Loop GUI NO TUI {Loop(Control)},{EndLoop} キーワード ジャーナル,ファイル,繰り返し文 Key Word Journal,File,Loop,statement ジャーナルファイルでLoopステートメントを使う方法について(Journal-Loop)...

三角形メッシュ内を四角形メッシュに分割する方法

カテゴリー 作成日/修正日 2015/9/14 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Mesh→Surface→Modify GUI NO TUI tquad surface <id> キーワード メッシュ,分割,三角形,四角形 Key Word Mesh,Triangle,Quadrangle 三角形メッシュ内を四角形メッシュに分割する方法について(Scheme-TQuad)...

各Blockに設定されているVolumeを変更する方法

カテゴリー 作成日/修正日 2015/10/10 2015/11/3 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Group→Block→Modify GUI Group→Block→Add TUI block <id> volume <id>s remove キーワード ブロック,ボリューム,変更 Key Word Block,Volume,Modify...

Viewカメラの位置を座標値で設定する方法

カテゴリー作成日/修正日2016/3/302016/3/30対応Trelisバージョン15.0.1 → 16.0.0カテゴリーDisplay → View → CameraGUINOTUIAt <#,#,#> From <#,#,#> Up<#,#,#>キーワードビュー,カメラ,視点,位置Key...

面の法線方向に押し出してVolumeを作成する方法

カテゴリー 作成日/修正日 2016/12/2 2016/12/2 対応Trelisバージョン 15.0.0 → 16.0.3 カテゴリー Geometry→ Volume → Create GUI Geometry→ Volume → Create →Sweep TUI sweep surface <id>s perpendicular distance <#> キーワード 面,押し出し,法線 Key Word Volume,Create,Surface,Sweep...

円の内部に境界層メッシュを作成する方法

カテゴリー 作成日/修正日 2016/12/4 2016/12/4 対応Trelisバージョン 15.0.0 → 16.0.3 カテゴリー Mesh→ Boundary Layer → Create GUI Mesh→ Boundary Layer → Create TUI boundary_layer 1 uniform height <#> growth <#> layers <#> キーワード 境界層,円,カーブ Key Word Boundary Layer,Circle,Curve...

Curveの方向を変える方法

カテゴリー 作成日/修正日 2015/8/1 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4 カテゴリー Geometry-→Curve→Modify GUI Geometry-→Curve→Modify →Sense TUI curve <id> tangent opposite キーワード カーブ,方向,変更 Key Word Curve,Direction,Modify, Sense,Tangent,Opposite Curveの方向を変えるには...

最新のドキュメント

3点を通る円Surfaceを作成する方法

3点を通る円Surfaceを作成する方法

カテゴリー 作成日/修正日 2015/9/10 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Geometry→Surface→Create GUI Geometry→Surfaces→Create→Circle→Vertex List TUI create surface circle vertex <id> <id> <id> キーワード 円,3点,面 Key Word...

3点を通る円Curveを作成する方法

3点を通る円Curveを作成する方法

カテゴリー 作成日/修正日 2015/9/9 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Geometry→Curve→Create GUI Geometry→Curves→Create→Arc or Circle→Center Angle TUI create curve arc radius <#> center location <#> <#> <#> normal <#>...

機能別チュートリアル一覧

絵を描くには、たった5つの操作を理解するだけでOKです。基本的には、作成だけでできますが、便利な機能として、ブーリアン、移動、削除、さらに修正が利用できます。


Create (作成)は、形状を新たに作成したり、既存の形状から作成したりする機能です。


 

Modify (編集・修正・修復)は、既存の形状を編集や微修正を行ったり、壊れた形状を修復する機能です。修復は、特に他のCADから形状を読み込んだ場合に形状が壊れているときに利用します。修復機能で形状が修復できない場合は、元のCADから互換性の良い型式で出力したり、場合によっては、元のCADで修正を行う必要があります。


 

Boolean (ブーリアン)は、形状を足し算したり、引き算すしたり、掛け算(共通部分)を行う機能です。一般的に、和、差、積と言われます。この他、Cubitには、ブーリアン系のコマンドとして、Imprint/MergeやWebcutが利用できます。Imprintは、交線を求める機能、Mergeは、同じ形の形状が同じ場所にあった場合に連結する機能です。Webcutはサーフェースやボリューム、ボディなどで既存の形状を分割する機能です


 

Translate (座標変換)は、形状を移動、回転、反転、スケーリングする機能です。


 

Delete (削除)は、形状を削除する機能です。Cubitでは、下位のジオメトリを残して削除することが可能です。


 

Webcut (形状分割)は、形状を分割する機能です。ヘキサメッシュ作成に先立ち、Webcut機能で、ヘキサメッシュ可能な形状に分割していきます。ヘキサメッシュ作成に必要な作業は、この分割作業に尽きます。ヘキサメッシュを作成するために行うべき作業は、ManyToManyタイプの形状をManyToOneまたは、OneToOneに分割するだけです。Cubitでは、この作業のために便利なWebcutツールを提供しております。


 

Virtual Geometry (バーチャルジオメトリ)は、CADのSolidモデリング機能(Real Geometry)では、対応できない、面の合成や面の分割をする機能です。一般的にCADでは、連続性のある面しか合成できません。また、CADは、メッシュを作成することを意識して開発しておらず、実際の物体の表面を表現するために、複数の数学的に定義可能な連続な面に分けて物体の表面を表現します。このように複数に分けて定義されたサーフェースに対して、ユーザーが希望するメッシュを作成することができない場合があります。CubitのVirtual Geometry機能を利用すると、CAD機能で合成できない数学的に連続性のない面を仮想的に合成することができます。