形状メッシュから形状を持たないフリーメッシュを作成する方法

カテゴリー 作成日/修正日 2015/10/24 2015/11/3 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Mesh→Create→Free-Mesh GUI Mesh→Volume→Create Mesh Based Geometry→Disassociate Mesh TUI disassociate mesh from volume <id> キーワード フリーメッシュ,作成,抽出 Key Word Free...

指定したNodeのID番号を変更する方法

カテゴリー 作成日/修正日 2017/3/17 2017/3/17 対応Trelisバージョン 15.0.0 → 16.0.3 カテゴリー Mesh→Node→ Modify GUI Mesh→Nodes→ Renumber TUI renumber node <#> start_id <#> uniqueids キーワード ノード,接点,番号,変更 Key Word Mesh,Node ID,Renumber 指定したNodeのID番号を変更する方法(Mesh_Renumber_Node_ID)...

複数のVertexからSpline 曲線を作成する方法

カテゴリー 作成日/修正日 2015/9/5 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Geometry→Curve→Create GUI Geometry→Curves→Create→Spline→Vertex TUI create curve spline vertex <id>s キーワード スプライン Key Word Spline,Veryex 複数のVertexから曲線Spline Curve...

内・外円の半径を指定してドーナッツ形状を作成する方法

カテゴリー 作成日/修正日 2015/09/11 22015/11/04 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Geometry→Surface→Create GUI Geometry→Volumes→Create→Torus TUI create torus major radius <#> minor radius <#> キーワード ドーナッツ Key Word Torus,Radius...

形状全体をスケールする方法

カテゴリー 作成日/修正日 2015/8/31 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4 カテゴリー Geometry→Volume→Modify GUI Geometry→Volumes→Transforms→Scale TUI volume <id> scale <#> キーワード 形状,拡大,縮小,スケール Key Word Geometry,Scale 形状全体をスケールする方法について(Geometry-Scale)...

六面体メッシュ内を四面体メッシュに分割する方法

カテゴリー 作成日/修正日 2015/9/14 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Mesh→Volume→Modify GUI NO TUI htet volume <id> キーワード メッシュ,分割,四面体,六面体 Key Word Mesh,Tetra,hexahedron 六面体メッシュ内を四面体メッシュに分割する方法について(Scheme-HTet)...

指定したEdgeのID番号を変更する方法

カテゴリー 作成日/修正日 2017/3/18 2017/3/18 対応Trelisバージョン 15.0.0 → 16.0.3 カテゴリー Mesh→Edge→ Modify GUI Mesh→Edges→ Renumber TUI renumber edge <#> start_id <#> uniqueids キーワード エッジ,接点,番号,変更 Key Word Mesh,Edge ID,Renumber 指定したEdgeのID番号を変更する方法(Mesh_Renumber_Edge_ID)...

メッシュが作成されていないVolumeのみを表示する方法

カテゴリー 作成日/修正日 2015/8/23 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4 カテゴリー Display→Mesh→Meshed GUI NO TUI draw volume with not is_meshed キーワード メッシュ,表示,非表示 Key Word draw, meshed,volume メッシュが作成されていないVolumeのみを表示する方法について(Draw-Meshed)...

Viewの拡大・縮小をコマンド(TUI)で表示する方法

カテゴリー作成日/修正日2016/4/52016/4/5対応Trelisバージョン15.0.1 → 16.0.0カテゴリーDisplay → View → ZoomGUINOTUIzoom screen <#>キーワードビュー,拡大,縮小,アニメーションKey...

中心と長軸・短軸のVertexを指定して楕円Surfaceを作成する方法

カテゴリー 作成日/修正日 2015/9/11 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Geometry→Surface→Create GUI Geometry→Surfaces→Create→Ellipse→Vertex List TUI create surface ellipse vertex <id> <id> <id> キーワード 楕円,3点 Key Word...

最新のドキュメント

半径を指定して正多角推を作成する方法

半径を指定して正多角推を作成する方法

カテゴリー 作成日/修正日 2015/9/12 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Geometry→Surface→Create GUI Geometry→Volumes→Create→Pyramid TUI create pyramid height <#> sides <#> radius <#> top 0 キーワード 正多角推 Key Word Regular,Pyramid,Radius...

機能別チュートリアル一覧

絵を描くには、たった5つの操作を理解するだけでOKです。基本的には、作成だけでできますが、便利な機能として、ブーリアン、移動、削除、さらに修正が利用できます。


Create (作成)は、形状を新たに作成したり、既存の形状から作成したりする機能です。


 

Modify (編集・修正・修復)は、既存の形状を編集や微修正を行ったり、壊れた形状を修復する機能です。修復は、特に他のCADから形状を読み込んだ場合に形状が壊れているときに利用します。修復機能で形状が修復できない場合は、元のCADから互換性の良い型式で出力したり、場合によっては、元のCADで修正を行う必要があります。


 

Boolean (ブーリアン)は、形状を足し算したり、引き算すしたり、掛け算(共通部分)を行う機能です。一般的に、和、差、積と言われます。この他、Cubitには、ブーリアン系のコマンドとして、Imprint/MergeやWebcutが利用できます。Imprintは、交線を求める機能、Mergeは、同じ形の形状が同じ場所にあった場合に連結する機能です。Webcutはサーフェースやボリューム、ボディなどで既存の形状を分割する機能です


 

Translate (座標変換)は、形状を移動、回転、反転、スケーリングする機能です。


 

Delete (削除)は、形状を削除する機能です。Cubitでは、下位のジオメトリを残して削除することが可能です。


 

Webcut (形状分割)は、形状を分割する機能です。ヘキサメッシュ作成に先立ち、Webcut機能で、ヘキサメッシュ可能な形状に分割していきます。ヘキサメッシュ作成に必要な作業は、この分割作業に尽きます。ヘキサメッシュを作成するために行うべき作業は、ManyToManyタイプの形状をManyToOneまたは、OneToOneに分割するだけです。Cubitでは、この作業のために便利なWebcutツールを提供しております。


 

Virtual Geometry (バーチャルジオメトリ)は、CADのSolidモデリング機能(Real Geometry)では、対応できない、面の合成や面の分割をする機能です。一般的にCADでは、連続性のある面しか合成できません。また、CADは、メッシュを作成することを意識して開発しておらず、実際の物体の表面を表現するために、複数の数学的に定義可能な連続な面に分けて物体の表面を表現します。このように複数に分けて定義されたサーフェースに対して、ユーザーが希望するメッシュを作成することができない場合があります。CubitのVirtual Geometry機能を利用すると、CAD機能で合成できない数学的に連続性のない面を仮想的に合成することができます。