Volume-Meshの各要素をN分割して細分化する方法

カテゴリー 作成日/修正日 2015/10/6 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4 カテゴリー Mesh→Volume→Refine→Split GUI Mesh→Volume→Refine→General Refinement→Split TUI refine volume <id> numsplit <#> smooth キーワード メッシュ,ボリューム,細分化,半分 Key Word Mesh , Volume,...

VolumeのID番号を変更する方法

カテゴリー 作成日/修正日 2015/8/21 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4 カテゴリー Identity→Volume→Modify GUI NO TUI Volume <old_id> id <new_id> キーワード 識別,変更,ボリューム Key Word Identity,Modify,Volume VolumeのID番号を変更する方法について(Volume-ID)...

螺旋形状のVolumeを作成する方法

カテゴリー 作成日/修正日 2016/10/10 2016/10/10 対応Trelisバージョン 15.0.0 → 16.0.3 カテゴリー Geometry→ Create→ Volume GUI Geometry→ Create → Volume→Sweep TUI sweep surface <#>helix  キーワード 押し出し,螺旋 Key Word Crate,Volume,Sweep,Helix, 螺旋形状のVolumeを作成する方法について(Sweep-Surface-Helix)...

2点を結ぶ直線を軸にする円筒曲面で立体形状を分割する方法

カテゴリー 作成日/修正日 2015/10/9 2015/10/9 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4 カテゴリー Geometry→Volume→Modify GUI Geometry→Volume→Webcutting→Cylinder TUI webcut body <id> with cylinder radius <#> axis vertex <id> vertex <id> キーワード 立体,分割,曲面,曲面,円筒,2点...

Curve上に分割数と両端からの拡大率を指定してNodeを作成する方法

カテゴリー 作成日/修正日 2015/9/15 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Mesh→Curve→Create GUI Mesh→Curves→Attribute→bias→Intervals & bias→Dual bias TUI curve <id> scheme dualbias factor <#> <#> キーワード メッシュ,ノード,拡大率,分割数 Key Word...

面のメッシュを境界線から垂直方向になるように修正する方法

カテゴリー 作成日/修正日 2015/9/19 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Mesh→Surface→Modify GUI Mesh→Surface→Smoothing→Orthogonal TUI adjust boundary orthogonal surface <id> snap_to_normal curve <id> fixed curve <id> キーワード...

Vertexを指定した座標に移動させる方法

カテゴリー 作成日/修正日 2015/9/26 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Geometry→Vertex→Translate GUI Geometry→Vertex→Transform→Move→Coordinate TUI move vertex <id> location <#> <#> <#> include_merged キーワード 接点,移動,座標 Key Word...

四角形状面に四角形メッシュを左右対称に作成する方法

カテゴリー 作成日/修正日 2015/9/13 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Mesh→Surface→Create GUI NO TUI surface <#> scheme stransition キーワード 対称,メッシュ,四角形 Key Word STransition,Symmetry 三角形状面に四角形メッシュを左右対称に作成する方法について(Scheme Stransition)...

円形状面に放射状の四角形メッシュを作成する方法

カテゴリー 作成日/修正日 2015/9/19 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4,15.1.5 カテゴリー Mesh→Surface→Create GUI Mesh→Surface→Scheme→Circle TUI surface <id> scheme circle interval <#> fraction <#> キーワード メッシュ,円,スキーム Key Word Mesh,Scheme,Circle...

プリズム要素を作成する方法

カテゴリー 作成日/修正日 2015/8/1 2015/11/4 対応Cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4 カテゴリー Mesh→Volume→Scheme →Wedge GUI Mesh→Volume→Sweep TUI volume <id> scheme sweep transform least_squares キーワード メッシュ,スキーム,ウエッジ,プリズム Key Word Mesh,Scheme,Wedge...

最新のドキュメント

ロッドヒーターシミュレーションの反復設計を迅速化

ロッドヒーターシミュレーションの反復設計を迅速化

Coreform CubitとMOOSEを使用したロッドヒーターシミュレーションのための迅速な反復設計とメッシュ精細化 Coreform Cubitは、原子力エネルギーやその他のアプリケーションにおけるMOOSEのオープンソースシミュレーションを加速するために使用できます。 このウェビナーでは、Quartermaster Consultingの創設者であるポール・キューテリアン氏が、Coreform...

Curveの方向を変える方法(Curve-Sense)

Curveの方向を変える方法(Curve-Sense)

Curveの方向を変える方法(Curve-Sense) カテゴリー 作成日/修正日 2015/08/01 2024/10/20 対応cubitバージョン 15.0.1, 15.0.4, 15.1.2,15.1.4→2024.8 カテゴリー Geometry-→Curve→Modify GUI Geometry-→Curve→Modify →Sense TUI curve <id> tangent opposite キーワード カーブ,方向,変更 Key Word Curve,Direction,Modify,...

Curveの方向を変える方法(Geometry→Modify→Curve→Sense)

Curveの方向を変える方法(Geometry→Modify→Curve→Sense)

Curveの方向を変える方法 (Geometry→Modify→Curve→Sense) カテゴリー 作成日/修正日 2015/08/01 2024/10/20 対応cubitバージョン 16.3.0→2024.8 カテゴリー Geometry-→Curve→Modify GUI Geometry-→Modify →Curves→Sense TUI curve <id> tangent opposite キーワード カーブ,方向,変更 Key Word Curve,Direction,Modify,...

格子状の曲線群で自由曲面を作成する方法

格子状の曲線群で自由曲面を作成する方法

格子状の曲線群で自由曲面を作成する方法(Create_Surface_Net_Curve) カテゴリー 作成日/修正日 2017/3/25 2017/3/25 対応Trelisバージョン 16.2.2 → 16.3.0 カテゴリー Geometry→Surface→Crate GUI Geometry→Create→Surface→Net Surface TUI create surface net u curve <id>s v curve <id>s heal キーワード 自由曲面,ガイド曲線,格子...

Sample Curveの方向を変える方法

Sample Curveの方向を変える方法

Curveの方向はGeometry-→Curves→Modify Curves→Senseで変更することができます。方向の確認をしてから変更したいCurveを選んで向きを変えることが出来ます。 Step 1:Curveの方向の確認 Geometry-→Curves→Modify Curves→SenseでCurve IDを指定(ここではall)します。 Enterを押します。 Curveの方向がベクトルで表示されます。 図 1:カーブの方向の表示 Step 2:Curveの方向の変更 Geometry-→Curves→Modify...

特定のGroup内のEntityを表示する方法

特定のGroup内のEntityを表示する方法

カテゴリー 作成日/修正日 2017/3/24 2017/3/24 対応Trelisバージョン 16.2.2 → 16.3.0 カテゴリー Draw→Group→ Entity GUI Draw→Group→ Entity TUI draw ENTITY in volume in group <$$$> キーワード グループ,エンティティー,表示 Key Word Draw,Entity,Group 特定のGroup内のEntityを表示する方法(Draw_Entity_in_Group)...

機能別チュートリアル一覧

絵を描くには、たった5つの操作を理解するだけでOKです。基本的には、作成だけでできますが、便利な機能として、ブーリアン、移動、削除、さらに修正が利用できます。


Create (作成)は、形状を新たに作成したり、既存の形状から作成したりする機能です。


 

Modify (編集・修正・修復)は、既存の形状を編集や微修正を行ったり、壊れた形状を修復する機能です。修復は、特に他のCADから形状を読み込んだ場合に形状が壊れているときに利用します。修復機能で形状が修復できない場合は、元のCADから互換性の良い型式で出力したり、場合によっては、元のCADで修正を行う必要があります。


 

Boolean (ブーリアン)は、形状を足し算したり、引き算すしたり、掛け算(共通部分)を行う機能です。一般的に、和、差、積と言われます。この他、Cubitには、ブーリアン系のコマンドとして、Imprint/MergeやWebcutが利用できます。Imprintは、交線を求める機能、Mergeは、同じ形の形状が同じ場所にあった場合に連結する機能です。Webcutはサーフェースやボリューム、ボディなどで既存の形状を分割する機能です


 

Translate (座標変換)は、形状を移動、回転、反転、スケーリングする機能です。


 

Delete (削除)は、形状を削除する機能です。Cubitでは、下位のジオメトリを残して削除することが可能です。


 

Webcut (形状分割)は、形状を分割する機能です。ヘキサメッシュ作成に先立ち、Webcut機能で、ヘキサメッシュ可能な形状に分割していきます。ヘキサメッシュ作成に必要な作業は、この分割作業に尽きます。ヘキサメッシュを作成するために行うべき作業は、ManyToManyタイプの形状をManyToOneまたは、OneToOneに分割するだけです。Cubitでは、この作業のために便利なWebcutツールを提供しております。


 

Virtual Geometry (バーチャルジオメトリ)は、CADのSolidモデリング機能(Real Geometry)では、対応できない、面の合成や面の分割をする機能です。一般的にCADでは、連続性のある面しか合成できません。また、CADは、メッシュを作成することを意識して開発しておらず、実際の物体の表面を表現するために、複数の数学的に定義可能な連続な面に分けて物体の表面を表現します。このように複数に分けて定義されたサーフェースに対して、ユーザーが希望するメッシュを作成することができない場合があります。CubitのVirtual Geometry機能を利用すると、CAD機能で合成できない数学的に連続性のない面を仮想的に合成することができます。